Removes a coping (cut) from a steel beam.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- cutter
- Type: Autodesk.Revit.DBFamilyInstance
A steel beam or column for which this beam currently has a coping cut. May not be a null reference (Nothing in Visual Basic) or itself.
Remarks
This function corresponds to Tools -> Remove coping in Revit Structure.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | Thrown when 'cutter' is a null reference (Nothing in Visual Basic). |
Autodesk.Revit.ExceptionsArgumentException | Thrown when 'cutter' refers to this instance. |
Autodesk.Revit.ExceptionsInvalidOperationException | Thrown when regeneration fails. |