RemoveCoping Method


Family Instance Remove Coping Method

Removes a coping (cut) from a steel beam.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool RemoveCoping(
	FamilyInstance cutter
)

Parameters

cutter FamilyInstance
A steel beam or column for which this beam currently has a coping cut. May not be or itself.

Return Value

Boolean
Exceptions
Exception Condition
ArgumentNullException Thrown when 'cutter' is .
ArgumentException Thrown when 'cutter' refers to this instance.
InvalidOperationException Thrown when regeneration fails.
Remarks
This function corresponds to Tools -> Remove coping in Revit Structure.
See Also