Create Method (Document, ElementId)


Creates a sketch plane from a grid, reference plane, or level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2014

Syntax

C#
public static SketchPlane Create(
	Document document,
	ElementId datumId
)
Visual Basic
Public Shared Function Create ( _
	document As Document, _
	datumId As ElementId _
) As SketchPlane
Visual C++
public:
static SketchPlane^ Create(
	Document^ document, 
	ElementId^ datumId
)

Parameters

document
Type: Autodesk.Revit.DBDocument
The document.
datumId
Type: Autodesk.Revit.DBElementId
The id of the grid, reference plane, or level.

Return Value

The newly created sketch plane.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException datumId is not a valid Element identifier. -or- ElementId must correspond to a grid, reference plane, or level. -or- ElementId must correspond to a non-curved datum. -or- Sketch plane creation is not allowed in this family.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsModificationForbiddenException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.ExceptionsModificationOutsideTransactionException The document has no open transaction.

See Also