Create Method (Document, ElementId)


Sketch Plane Create(Document, Element Id) Method

Creates a sketch plane from a grid, reference plane, or level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static SketchPlane Create(
	Document document,
	ElementId datumId
)

Parameters

document Document
The document.
datumId ElementId
The id of the grid, reference plane, or level.

Return Value

SketchPlane
The newly created sketch plane.
Exceptions
Exception Condition
ArgumentException datumId is not a valid Element identifier. -or- ElementId must correspond to a grid, reference plane, or level. -or- ElementId must correspond to a non-curved datum. -or- Sketch plane creation is not allowed in this family.
ArgumentNullException A non-optional argument was null
ModificationForbiddenException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException The document has no open transaction.
See Also