Verify the uniqueness of the name among all registered result schemas.
Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- name
- Type: SystemString
Name to verify uniqueness of.
- resultIndexToSkip
- Type: SystemInt32
Index of result (e.g. to be replaced) which names should not count for uniqueness; negative number means nothing is excluded from comparison.
Return Value
True if name is unique, false otherwise.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |