Generate a new spot coordinate object within the project.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- view
- Type: Autodesk.Revit.DBView
The view in which the spot coordinate is to be visible.
- reference
- Type: Autodesk.Revit.DBReference
The reference to which the spot coordinate is to be bound.
- origin
- Type: Autodesk.Revit.DBXYZ
The point which the spot coordinate evaluate.
- bend
- Type: Autodesk.Revit.DBXYZ
The bend point for the spot coordinate.
- end
- Type: Autodesk.Revit.DBXYZ
The end point for the spot coordinate.
- refPt
- Type: Autodesk.Revit.DBXYZ
The actual point on the reference which the spot coordinate evaluate.
- hasLeader
- Type: SystemBoolean
Indicate if it has leader or not.
Return Value
If successful a new spot dimension object, otherwise a null reference (Nothing in Visual Basic).Remarks
If the origin point is not on the reference, it'll be projected to the reference automatically. And the refPt is projected point. If the reference is not valid or the point cannot be projected to reference correctly, an exception will be thrown
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | Thrown if the view does not exist in the given document. |