Document New |
Generate a new spot coordinate object within the project.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public SpotDimension NewSpotCoordinate(
View view,
Reference reference,
XYZ origin,
XYZ bend,
XYZ end,
XYZ refPt,
bool hasLeader
)
Parameters
- view View
- The view in which the spot coordinate is to be visible.
- reference Reference
- The reference to which the spot coordinate is to be bound.
- origin XYZ
- The point which the spot coordinate evaluate.
- bend XYZ
- The bend point for the spot coordinate.
- end XYZ
- The end point for the spot coordinate.
- refPt XYZ
- The actual point on the reference which the spot coordinate evaluate.
- hasLeader Boolean
- Indicate if it has leader or not.
Return Value
SpotDimensionIf successful a new spot dimension object, otherwise .

Exception | Condition |
---|---|
ArgumentException | Thrown if the view does not exist in the given document. |

If the origin point is not on the reference, it'll be projected to the reference automatically. And the refPt is projected point. If the reference is not valid or the point cannot be projected to reference correctly, an exception will be thrown