Creates a new DisplacementPath referencing a DisplacementElement and edge or curve and adds it to the document.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- aDoc
- Type: Autodesk.Revit.DBDocument
The document.
- displacementElement
- Type: Autodesk.Revit.DBDisplacementElement
Element id of a DisplacementElement
- reference
- Type: Autodesk.Revit.DBReference
A reference that refers to an edge or curve of one of the elements displaced by the displacementElement.
- param
- Type: SystemDouble
A value in the range [0,1]. It will be interpreted as a parameter for the specified edge.
Return Value
The element id of the newly created DisplacementPath.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The value param should lie in the range [0,1]. -or- reference does not represent an edge or curve belonging to an element displaced by displacementElement. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |