Create Method


Displacement Path Create Method

Creates a new DisplacementPath referencing a DisplacementElement and edge or curve and adds it to the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static ElementId Create(
	Document aDoc,
	DisplacementElement displacementElement,
	Reference reference,
	double param
)

Parameters

aDoc Document
The document.
displacementElement DisplacementElement
Element id of a DisplacementElement
reference Reference
A reference that refers to an edge or curve of one of the elements displaced by the displacementElement.
param Double
A value in the range [0,1]. It will be interpreted as a parameter for the specified edge.

Return Value

ElementId
The element id of the newly created DisplacementPath.
Exceptions
Exception Condition
ArgumentException The value param should lie in the range [0,1]. -or- reference does not represent an edge or curve belonging to an element displaced by displacementElement.
ArgumentNullException A non-optional argument was null
See Also