Checks if given type is valid for this element.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- typeId
- Type: Autodesk.Revit.DBElementId
ElementId of the type to check.
Return Value
True if element can have a type assigned and this type is valid for this element, false otherwise.Remarks
A type is valid for an element if it can be assigned to the element.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |