Element Is |
Checks if given type is valid for this element.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- typeId ElementId
- ElementId of the type to check.
Return Value
BooleanTrue if element can have a type assigned and this type is valid for this element, false otherwise.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |

A type is valid for an element if it can be assigned to the element.