Create DGN export settings with specified values in DGNExportOptions.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DBDocument
Document where created settings is saved.
- name
- Type: SystemString
The name specified to this settings.
- options
- Type: Autodesk.Revit.DBDGNExportOptions
The options which will be stored in these settings.
Return Value
The new DGN export settings instance.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | ExistOrEmpty |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |