GetLevelInfo Method


Returns an object representing the information about a level in the document.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public IFCLevelInfo GetLevelInfo(
	ElementId levelId
)
Visual Basic
Public Function GetLevelInfo ( _
	levelId As ElementId _
) As IFCLevelInfo
Visual C++
public:
IFCLevelInfo^ GetLevelInfo(
	ElementId^ levelId
)

Parameters

levelId
Type: Autodesk.Revit.DBElementId
The level id.

Return Value

The level information.

Remarks

Level information is currently automatically collected and cached in the ExporterIFC object. This method returns the cached information for a given level, which is often needed during export of particular building elements which reference levels, as well as to implement automatic wall and column splitting.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also