GetLevelInfo Method


Exporter IFC Get Level Info Method

Note: This API is now obsolete.

Returns an object representing the information about a level in the document.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
[ObsoleteAttribute("This is deprecated in Revit 2026.  Use ExporterCacheManager.LevelInfoCache.LevelsById instead.")]
public IFCLevelInfo GetLevelInfo(
	ElementId levelId
)

Parameters

levelId ElementId
The level id.

Return Value

IFCLevelInfo
The level information.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
Level information is currently automatically collected and cached in the ExporterIFC object. This method returns the cached information for a given level, which is often needed during export of particular building elements which reference levels, as well as to implement automatic wall and column splitting.
See Also