CanElementsBeDisplaced Method (View, ICollection(ElementId))


Indicates if elements can be assigned to a new DisplacementElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2014

Syntax

C#
public static bool CanElementsBeDisplaced(
	View view,
	ICollection<ElementId> elementIds
)
Visual Basic
Public Shared Function CanElementsBeDisplaced ( _
	view As View, _
	elementIds As ICollection(Of ElementId) _
) As Boolean
Visual C++
public:
static bool CanElementsBeDisplaced(
	View^ view, 
	ICollection<ElementId^>^ elementIds
)

Parameters

view
Type: Autodesk.Revit.DBView
The view.
elementIds
Type: System.Collections.GenericICollectionElementId
The element ids.

Remarks

A necessary condition is that isAllowedAsDisplacedElement returns true for each individual element id. In addition, if isElementDisplaced must return the same value for all the specified element ids.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also