CanElementsBeDisplaced Method (View, ICollection(ElementId))


Displacement Element Can Elements Be Displaced(View, ICollection Element Id ) Method

Indicates if elements can be assigned to a new DisplacementElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool CanElementsBeDisplaced(
	View view,
	ICollection<ElementId> elementIds
)

Parameters

view View
The view.
elementIds ICollection ElementId
The element ids.

Return Value

Boolean
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
A necessary condition is that isAllowedAsDisplacedElement returns true for each individual element id. In addition, if isElementDisplaced must return the same value for all the specified element ids.
See Also