Implement this method to return an iterator for iterating over blocks of this point cloud.
Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- rFilter
- Type: Autodesk.Revit.DB.PointCloudsPointCloudFilter
The filter used to process cloud points and determine which ones lie with the target volume.
- density
- Type: SystemDouble
Desired number of points per unit area. Area is computed in native units of the point cloud. Another iterator, created with the same density and a more restrictive filter, should return a subset of the points returned by this iterator.
- viewId
- Type: Autodesk.Revit.DBElementId
The view id for the current view passed as auxiliary information to allow the engine to optimize retrieval of points. If viewId == InvalidElementId, the query is not for a view display operation.