IPoint |
Implement this method to return an iterator for iterating over blocks of this point cloud.
Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

IPointSetIterator CreatePointSetIterator(
PointCloudFilter rFilter,
double density,
ElementId viewId
)
Parameters
- rFilter PointCloudFilter
- The filter used to process cloud points and determine which ones lie with the target volume.
- density Double
- Desired number of points per unit area. Area is computed in native units of the point cloud. Another iterator, created with the same density and a more restrictive filter, should return a subset of the points returned by this iterator.
- viewId ElementId
- The view id for the current view passed as auxiliary information to allow the engine to optimize retrieval of points. If viewId == InvalidElementId, the query is not for a view display operation.
Return Value
IPointSetIteratorThe newly created iterator.