The exception that is thrown when making or attempting to make changes that are forbidden during dynamic updates to the model.
Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Remarks
Modifications leading to a new mutual relationship between elements that did not depend on each other before are potentially not safe in work-set environment. This exception is thrown when an Updater either makes such modifications or attempts to call a method that will or may modify the model in such unsafe matter.
Inheritance Hierarchy
SystemObject
SystemException
Autodesk.Revit.ExceptionsApplicationException
Autodesk.Revit.ExceptionsInvalidOperationException
Autodesk.Revit.ExceptionsForbiddenForDynamicUpdateException
SystemException
Autodesk.Revit.ExceptionsApplicationException
Autodesk.Revit.ExceptionsInvalidOperationException
Autodesk.Revit.ExceptionsForbiddenForDynamicUpdateException