ForbiddenForDynamicUpdateException Class


Forbidden For Dynamic Update Exception Class

The exception that is thrown when making or attempting to make changes that are forbidden during dynamic updates to the model.
Inheritance Hierarchy

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
[SerializableAttribute]
public class ForbiddenForDynamicUpdateException : InvalidOperationException

The ForbiddenForDynamicUpdateException type exposes the following members.

Properties
Name Description
Top
Methods
Name Description
Public method GetObjectData Retrieves data needed to serialize the target object.
(Overrides InvalidOperationException GetObjectData(SerializationInfo, StreamingContext) )
Top
Remarks
Modifications leading to a new mutual relationship between elements that did not depend on each other before are potentially not safe in work-set environment. This exception is thrown when an Updater either makes such modifications or attempts to call a method that will or may modify the model in such unsafe matter.
See Also