ForbiddenForDynamicUpdateException Class


Forbidden For Dynamic Update Exception Class

The exception that is thrown when making or attempting to make changes that are forbidden during dynamic updates to the model.
Inheritance Hierarchy

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
[SerializableAttribute]
public class ForbiddenForDynamicUpdateException : InvalidOperationException

The ForbiddenForDynamicUpdateException type exposes the following members.

Properties
Name Description
Public property Data Gets a collection of key/value pairs that provide additional user-defined information about the exception.
(Inherited from Exception )
Public property FunctionId The information of the function throwing the exception.
(Inherited from ApplicationException )
Public property HelpLink Gets or sets a link to the help file associated with this exception.
(Inherited from Exception )
Public property HResult Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.
(Inherited from Exception )
Public property InnerException Gets the Exception instance that caused the current exception.
(Inherited from Exception )
Public property Message Gets a message that describes the current exception.
(Inherited from Exception )
Public property Source Gets or sets the name of the application or the object that causes the error.
(Inherited from Exception )
Public property StackTrace Gets a string representation of the immediate frames on the call stack.
(Inherited from Exception )
Public property TargetSite Gets the method that throws the current exception.
(Inherited from Exception )
Top
Methods
Name Description
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetBaseException When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
(Inherited from Exception )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetObjectData Retrieves data needed to serialize the target object.
(Overrides InvalidOperationException GetObjectData(SerializationInfo, StreamingContext) )
Public method GetType Gets the runtime type of the current instance.
(Inherited from Exception )
Public method ToString Creates and returns a string representation of the current exception.
(Inherited from Exception )
Top
Remarks
Modifications leading to a new mutual relationship between elements that did not depend on each other before are potentially not safe in work-set environment. This exception is thrown when an Updater either makes such modifications or attempts to call a method that will or may modify the model in such unsafe matter.
See Also