AddMullions Method


Add mullions on the specified segments of a grid. If any segment already has a mullion, no change is made to that segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ElementSet AddMullions(
	Curve segment,
	MullionType mullionType,
	bool oneSegmentOnly
)
Visual Basic
Public Function AddMullions ( _
	segment As Curve, _
	mullionType As MullionType, _
	oneSegmentOnly As Boolean _
) As ElementSet
Visual C++
public:
ElementSet^ AddMullions(
	Curve^ segment, 
	MullionType^ mullionType, 
	bool oneSegmentOnly
)

Parameters

segment
Type: Autodesk.Revit.DBCurve
Curve of the segment.
mullionType
Type: Autodesk.Revit.DBMullionType
The type of the mullion to add.
oneSegmentOnly
Type: SystemBoolean
If true, add one mullion to the specified segment, otherwise add mullions to all the segments of the matching grid line.

Return Value

If operation succeeds, the created mullions will be returned.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsInvalidOperationExceptionInvalid curtain grid line or invalid mullion type argument.

See Also