Curtain |
Add mullions on the specified segments of a grid. If any segment already has a mullion, no change is made to that segment.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public ElementSet AddMullions(
Curve segment,
MullionType mullionType,
bool oneSegmentOnly
)
Parameters
- segment Curve
- Curve of the segment.
- mullionType MullionType
- The type of the mullion to add.
- oneSegmentOnly Boolean
- If true, add one mullion to the specified segment, otherwise add mullions to all the segments of the matching grid line.
Return Value
ElementSetIf operation succeeds, the created mullions will be returned.

Exception | Condition |
---|---|
InvalidOperationException | Invalid curtain grid line or invalid mullion type argument. |