CheckProjectPhase Method


Checks that the input element is a project phase.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2011

Syntax

C#
public bool CheckProjectPhase(
	ElementId projectPhaseId
)
Visual Basic
Public Function CheckProjectPhase ( _
	projectPhaseId As ElementId _
) As Boolean
Visual C++
public:
bool CheckProjectPhase(
	ElementId^ projectPhaseId
)

Parameters

projectPhaseId
Type: Autodesk.Revit.DBElementId
The element to be checked.

Return Value

True if the input element is a project phase, false otherwise.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also