Scale a face/edge/curve/vertex of the form, by a specified origin and scale factor.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- subElementReference
- Type: Autodesk.Revit.DBReference
The geometry reference of face/edge/curve/vertex
- factor
- Type: SystemDouble
The scale factor, it should be large than zero.
- origin
- Type: Autodesk.Revit.DBXYZ
The origin where scale happens.