ScaleSubElement Method


Form Scale Sub Element Method

Scale a face/edge/curve/vertex of the form, by a specified origin and scale factor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void ScaleSubElement(
	Reference subElementReference,
	double factor,
	XYZ origin
)

Parameters

subElementReference Reference
The geometry reference of face/edge/curve/vertex
factor Double
The scale factor, it should be large than zero.
origin XYZ
The origin where scale happens.
See Also