Create Method (IList(XYZ), Boolean, HermiteSplineTangents)


Creates a Hermite spline with specified tangency at its endpoints.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2014

Syntax

C#
public static HermiteSpline Create(
	IList<XYZ> controlPoints,
	bool periodic,
	HermiteSplineTangents tangents
)
Visual Basic
Public Shared Function Create ( _
	controlPoints As IList(Of XYZ), _
	periodic As Boolean, _
	tangents As HermiteSplineTangents _
) As HermiteSpline
Visual C++
public:
static HermiteSpline^ Create(
	IList<XYZ^>^ controlPoints, 
	bool periodic, 
	HermiteSplineTangents^ tangents
)

Parameters

controlPoints
Type: System.Collections.GenericIListXYZ
The control points of the Hermite spline.
periodic
Type: SystemBoolean
True if the Hermite spline is to be periodic, false otherwise.
tangents
Type: Autodesk.Revit.DBHermiteSplineTangents
The object which indicates tangency at the start, the end, or both ends of the curve.

Return Value

The new HermiteSpline object.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The control points array is invalid, because it doesn't contain the minimum number of points (2).
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was NULL
Autodesk.Revit.ExceptionsArgumentsInconsistentException Curve length is too small for Revit's tolerance (as identified by Application.ShortCurveTolerance).
Autodesk.Revit.ExceptionsInvalidOperationException Unable to construct valid HermiteSpline from given inputs.

See Also