Create Method (IList(XYZ), Boolean, HermiteSplineTangents)


Hermite Spline Create(IList XYZ , Boolean, Hermite Spline Tangents) Method

Creates a Hermite spline with specified tangency at its endpoints.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static HermiteSpline Create(
	IList<XYZ> controlPoints,
	bool periodic,
	HermiteSplineTangents tangents
)

Parameters

controlPoints IList XYZ
The control points of the Hermite spline.
periodic Boolean
True if the Hermite spline is to be periodic, false otherwise.
tangents HermiteSplineTangents
The object which indicates tangency at the start, the end, or both ends of the curve.

Return Value

HermiteSpline
The new HermiteSpline object.
Exceptions
Exception Condition
ArgumentException The control points array is invalid, because it doesn't contain the minimum number of points (2).
ArgumentNullException A non-optional argument was NULL
ArgumentsInconsistentException Curve length is too small for Revit's tolerance (as identified by Application.ShortCurveTolerance).
InvalidOperationException Unable to construct valid HermiteSpline from given inputs.
See Also