RemoveSplitRegion Method


Removes one region in split crop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2016

Syntax

C#
public void RemoveSplitRegion(
	int regionIndex
)
Visual Basic
Public Sub RemoveSplitRegion ( _
	regionIndex As Integer _
)
Visual C++
public:
void RemoveSplitRegion(
	int regionIndex
)

Parameters

regionIndex
Type: SystemInt32
Index of region to be deleted (numbering starts with 0).

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The provided region index cannot be deleted.
Autodesk.Revit.ExceptionsInvalidOperationException The crop of the associated view is not permitted to have multiple regions. -or- The view has non-rectangular crop shape set.

See Also