ReferencesDontMatchReferenceCategory Method


Verifies that all of the references belongs to elements which doesn't match the reference category required by the MultiReferenceAnnotationType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2020

Syntax

C#
public bool ReferencesDontMatchReferenceCategory(
	IList<Reference> references
)
Visual Basic
Public Function ReferencesDontMatchReferenceCategory ( _
	references As IList(Of Reference) _
) As Boolean
Visual C++
public:
bool ReferencesDontMatchReferenceCategory(
	IList<Reference^>^ references
)

Parameters

references
Type: System.Collections.GenericIListReference
The references to test.

Return Value

Returns true if the element categories of all tested references do not match the element category required by the MultiReferenceAnnotationType.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also