ReferencesDontMatchReferenceCategory Method


Multi Reference Annotation Options References Dont Match Reference Category Method

Verifies that all of the references belongs to elements which doesn't match the reference category required by the MultiReferenceAnnotationType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool ReferencesDontMatchReferenceCategory(
	IList<Reference> references
)

Parameters

references IList Reference
The references to test.

Return Value

Boolean
Returns true if the element categories of all tested references do not match the element category required by the MultiReferenceAnnotationType.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also