IsElementArrayable Method


Indicates whether the input element is arrayable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static bool IsElementArrayable(
	Document aDoc,
	ElementId id
)
Visual Basic
Public Shared Function IsElementArrayable ( _
	aDoc As Document, _
	id As ElementId _
) As Boolean
Visual C++
public:
static bool IsElementArrayable(
	Document^ aDoc, 
	ElementId^ id
)

Parameters

aDoc
Type: Autodesk.Revit.DBDocument
The document.
id
Type: Autodesk.Revit.DBElementId
The element id.

Return Value

True if the input element is arrayable, false otherwise.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also