ImagePlacementOptions Constructor (XYZ, BoxPlacement)


Constructs a new ImagePlacementOptions for placing an ImageInstance

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2020

Syntax

C#
public ImagePlacementOptions(
	XYZ location,
	BoxPlacement placementPoint
)
Visual Basic
Public Sub New ( _
	location As XYZ, _
	placementPoint As BoxPlacement _
)
Visual C++
public:
ImagePlacementOptions(
	XYZ^ location, 
	BoxPlacement placementPoint
)

Parameters

location
Type: Autodesk.Revit.DBXYZ
The location where the image will be placed
placementPoint
Type: Autodesk.Revit.DBBoxPlacement
The point of the image that will be aligned to the location in the view

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also