Commit Method


Finishes the edit scope.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2014

Syntax

C#
public void Commit(
	IFailuresPreprocessor failurePreprocessor
)
Visual Basic
Public Sub Commit ( _
	failurePreprocessor As IFailuresPreprocessor _
)
Visual C++
public:
void Commit(
	IFailuresPreprocessor^ failurePreprocessor
)

Parameters

failurePreprocessor
Type: Autodesk.Revit.DBIFailuresPreprocessor
Callback to be invoked in the beginning of failure processing.

Remarks

All the changes made after starting the EditScope will be committed. Changes will be merged into one transaction.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsInvalidOperationException EditScope is not active. EditScope can only be committed or cancelled when it is active. -or- EditScope cannot be closed, for there is a transaction or transaction group still open in the document.

See Also