Edit |
Finishes the edit scope.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- failurePreprocessor IFailuresPreprocessor
- Callback to be invoked in the beginning of failure processing.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | EditScope is not active. EditScope can only be committed or cancelled when it is active. -or- EditScope cannot be closed, for there is a transaction or transaction group still open in the document. |

All the changes made after starting the EditScope will be committed. Changes will be merged into one transaction.