AddNewAssetAsColor Method


Adds a new AssetPropertyDouble4 property to the list containing a value matching the input color.

Namespace: Autodesk.Revit.DB.Visual
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2018.1

Syntax

C#
public void AddNewAssetAsColor(
	Color value
)
Visual Basic
Public Sub AddNewAssetAsColor ( _
	value As Color _
)
Visual C++
public:
void AddNewAssetAsColor(
	Color^ value
)

Parameters

value
Type: Autodesk.Revit.DBColor
The color value to add.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsInvalidOperationException The asset property is not editable.

See Also