MEPNetworkIterator Constructor (Document, MEPAnalyticalModelData, ConnectorDomainType)


Creates an iterator by the analytical model data to visit all connected components in the network.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2024

Syntax

C#
public MEPNetworkIterator(
	Document pADoc,
	MEPAnalyticalModelData seed,
	ConnectorDomainType eDomain
)
Visual Basic
Public Sub New ( _
	pADoc As Document, _
	seed As MEPAnalyticalModelData, _
	eDomain As ConnectorDomainType _
)
Visual C++
public:
MEPNetworkIterator(
	Document^ pADoc, 
	MEPAnalyticalModelData^ seed, 
	ConnectorDomainType eDomain
)

Parameters

pADoc
Type: Autodesk.Revit.DBDocument
The document of the analytical network.
seed
Type: Autodesk.Revit.DB.AnalysisMEPAnalyticalModelData
The analytical model data of the starting element.
eDomain
Type: Autodesk.Revit.DBConnectorDomainType
The domain of network that the iteration happens.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also