MEPNetwork |
Creates an iterator by the analytical model data to visit all connected components in the network.
Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public MEPNetworkIterator(
Document pADoc,
MEPAnalyticalModelData seed,
ConnectorDomainType eDomain
)
Parameters
- pADoc Document
- The document of the analytical network.
- seed MEPAnalyticalModelData
- The analytical model data of the starting element.
- eDomain ConnectorDomainType
- The domain of network that the iteration happens.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |