AddConstraintRadius Method


Specify a parameter to drive the radius of the shape.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2009

Syntax

C#
public void AddConstraintRadius(
	ElementId paramId,
	RebarShapeArcReferenceType arcRefType
)
Visual Basic
Public Sub AddConstraintRadius ( _
	paramId As ElementId, _
	arcRefType As RebarShapeArcReferenceType _
)
Visual C++
public:
void AddConstraintRadius(
	ElementId^ paramId, 
	RebarShapeArcReferenceType arcRefType
)

Parameters

paramId
Type: Autodesk.Revit.DBElementId
Id of a parameter to drive the constraint. To obtain the id of a shared parameter, call RebarShape.GetElementIdForExternalDefinition().
arcRefType
Type: Autodesk.Revit.DB.StructureRebarShapeArcReferenceType
Specify how the radius should be measured--to the interior of the bend, the centerline of the bar, or the exterior.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also