Rebar |
Specify a parameter to drive the radius of the shape.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public void AddConstraintRadius(
ElementId paramId,
RebarShapeArcReferenceType arcRefType
)
Parameters
- paramId ElementId
- Id of a parameter to drive the constraint. To obtain the id of a shared parameter, call RebarShape.GetElementIdForExternalDefinition().
- arcRefType RebarShapeArcReferenceType
- Specify how the radius should be measured--to the interior of the bend, the centerline of the bar, or the exterior.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |