Returns curve loops that define geometry of the area boundary conditions.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Return Value
The curve loop collection.Remarks
Boundary conditions should be BoundaryConditionsType::Area type. Otherwise exception is thrown.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsInvalidObjectException | Thrown when BoundaryConditions is not a BoundaryConditionsType::Area type. |