GetLoops Method


Boundary Conditions Get Loops Method

Returns curve loops that define geometry of the area boundary conditions.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public IList<CurveLoop> GetLoops()

Return Value

IList CurveLoop
The curve loop collection.
Exceptions
Exception Condition
InvalidObjectException Thrown when BoundaryConditions is not a BoundaryConditionsType::Area type.
Remarks
Boundary conditions should be BoundaryConditionsType::Area type. Otherwise exception is thrown.
See Also