CanCreateOnMultistoryStairs Method


Checks if more stairs paths can be added on the plan views of a multistory stairs.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public static bool CanCreateOnMultistoryStairs(
	Document document,
	LinkElementId multistoryStairsId
)
Visual Basic
Public Shared Function CanCreateOnMultistoryStairs ( _
	document As Document, _
	multistoryStairsId As LinkElementId _
) As Boolean
Visual C++
public:
static bool CanCreateOnMultistoryStairs(
	Document^ document, 
	LinkElementId^ multistoryStairsId
)

Parameters

document
Type: Autodesk.Revit.DBDocument
multistoryStairsId
Type: Autodesk.Revit.DBLinkElementId
The multistory stairs id.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also