GetHost Method


Gets a reference to the reinforcement element that this bending detail represent.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2024

Syntax

C#
public static Reference GetHost(
	Element bendingDetail
)
Visual Basic
Public Shared Function GetHost ( _
	bendingDetail As Element _
) As Reference
Visual C++
public:
static Reference^ GetHost(
	Element^ bendingDetail
)

Parameters

bendingDetail
Type: Autodesk.Revit.DBElement
The bending detail for which we want to get the host.

Return Value

Returns a reference pointing to the reinforcement element represented by the input bending detail.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also