Constructs an AlphanumericRevisionSettings object.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- sequence
- Type: System.Collections.GenericIListString
The custom sequence to be used as numbers for revisions with the Alphanumeric RevisionNumberType.
If there are more alphanumeric revisions than there are strings in the sequence, subsequent alphanumeric revisions will be assigned duplicated characters. For example, if the sequence provided were ["X", "Y"], the first alphanumeric revision would be shown as "X", the second as "Y", the third as "XX", then "YY", "XXX", etc.
- prefix
- Type: SystemString
The prefix string for each revision number in the sequence.
- suffix
- Type: SystemString
The suffix string for each revision number in the sequence.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | Input sequence contains invalid entries. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |