AlphanumericRevisionSettings Constructor (IList(String), String, String)


Alphanumeric Revision Settings(IList String , String, String) Constructor

Constructs an AlphanumericRevisionSettings object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public AlphanumericRevisionSettings(
	IList<string> sequence,
	string prefix,
	string suffix
)

Parameters

sequence IList String

The custom sequence to be used as numbers for revisions with the Alphanumeric RevisionNumberType.

If there are more alphanumeric revisions than there are strings in the sequence, subsequent alphanumeric revisions will be assigned duplicated characters. For example, if the sequence provided were ["X", "Y"], the first alphanumeric revision would be shown as "X", the second as "Y", the third as "XX", then "YY", "XXX", etc.

prefix String
The prefix string for each revision number in the sequence.
suffix String
The suffix string for each revision number in the sequence.
Exceptions
Exception Condition
ArgumentException Input sequence contains invalid entries.
ArgumentNullException A non-optional argument was null
See Also