FinishLoop Method


Indicates that the caller has finished defining the given loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2016

Syntax

C#
public void FinishLoop(
	BRepBuilderGeometryId loopId
)
Visual Basic
Public Sub FinishLoop ( _
	loopId As BRepBuilderGeometryId _
)
Visual C++
public:
void FinishLoop(
	BRepBuilderGeometryId^ loopId
)

Parameters

loopId
Type: Autodesk.Revit.DBBRepBuilderGeometryId
Id of the loop.

Remarks

No functions that modify the given loop's definition should be called after calling this function (e.g., AddCoEdge(BRepBuilderGeometryId, BRepBuilderGeometryId, Boolean)). The BRepBuilder may take the opportunity to validate some of the loop's data and report any problems it finds.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The supplied loop id doesn't correspond to a loop stored in this BRepBuilder object. -or- FinishLoop() has already been called on loopId. -or- The edge loop has fewer than two co-edges.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also