FinishLoop Method


BRep Builder Finish Loop Method

Indicates that the caller has finished defining the given loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void FinishLoop(
	BRepBuilderGeometryId loopId
)

Parameters

loopId BRepBuilderGeometryId
Id of the loop.
Exceptions
Exception Condition
ArgumentException The supplied loop id doesn't correspond to a loop stored in this BRepBuilder object. -or- FinishLoop() has already been called on loopId. -or- The edge loop has fewer than two co-edges.
ArgumentNullException A non-optional argument was null
Remarks
No functions that modify the given loop's definition should be called after calling this function (e.g., AddCoEdge(BRepBuilderGeometryId, BRepBuilderGeometryId, Boolean) ). The BRepBuilder may take the opportunity to validate some of the loop's data and report any problems it finds.
See Also