SetExternalGeometryId Method


Sets the ExternalGeometryId associated with the reference object. The ID must be non-empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2024

Syntax

C#
public DirectShapeReferenceOptions SetExternalGeometryId(
	ExternalGeometryId externalId
)
Visual Basic
Public Function SetExternalGeometryId ( _
	externalId As ExternalGeometryId _
) As DirectShapeReferenceOptions
Visual C++
public:
DirectShapeReferenceOptions^ SetExternalGeometryId(
	ExternalGeometryId^ externalId
)

Parameters

externalId
Type: Autodesk.Revit.DBExternalGeometryId

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException externalId cannot be used as an ExternalGeometryId for a direct shape reference.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also