Direct |
Sets the ExternalGeometryId associated with the reference object. The ID must be non-empty.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public DirectShapeReferenceOptions SetExternalGeometryId(
ExternalGeometryId externalId
)
Parameters
- externalId ExternalGeometryId
Return Value
DirectShapeReferenceOptions
Exception | Condition |
---|---|
ArgumentException | externalId cannot be used as an ExternalGeometryId for a direct shape reference. |
ArgumentNullException | A non-optional argument was null |