GetValidSymbols Method (ForgeTypeId)


Gets the identifiers of all valid symbols for a given unit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2014

Syntax

C#
public static IList<ForgeTypeId> GetValidSymbols(
	ForgeTypeId unitTypeId
)
Visual Basic
Public Shared Function GetValidSymbols ( _
	unitTypeId As ForgeTypeId _
) As IList(Of ForgeTypeId)
Visual C++
public:
static IList<ForgeTypeId^>^ GetValidSymbols(
	ForgeTypeId^ unitTypeId
)

Parameters

unitTypeId
Type: Autodesk.Revit.DBForgeTypeId
Identifier of the unit.

Return Value

Identifiers of the valid symbols.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException unitTypeId is not a unit identifier. See UnitUtils.IsUnit(ForgeTypeId) and UnitUtils.GetUnitTypeId(DisplayUnitType).
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also